Mumpster
https://www.mumpster.org/

Windows version of MUMPS V1 now available on SourceForge.
https://www.mumpster.org/viewtopic.php?f=2&t=1711
Page 1 of 1

Author:  raynewman [ Sun Jul 29, 2012 12:27 am ]
Post subject:  Windows version of MUMPS V1 now available on SourceForge.

Version 1.58 of MUMPS now runs on Windows (only XP has been tested).
Get http://sourceforge.net/projects/mumps/f ... z/download
Also http://cygwin.com/setup.exe to install Cygwin which is required for shared
memory and semaphore support.

Alternatively use cvs to get the source and build from source.
cvs -z3 -d:pserver:anonymous@mumps.cvs.sf.net:/cvsroot/mumps checkout -P mumps
and read BUILD.

Please let us know how you go.

Ray Newman

Author:  whitten [ Wed Nov 07, 2012 7:40 am ]
Post subject:  Re: Windows version of MUMPS V1 now available on SourceForge

I didn't notice this earlier.

Kudos on this work!

Author:  cais28 [ Thu Jan 10, 2013 4:25 am ]
Post subject:  Re: Windows version of MUMPS V1 now available on SourceForge

Hi All

This 'mumps.exe' for Windows on Cygwin , working perfect on WindowsXP(32 bit) .
But , when I'm experienced on Windows7Ultimate(32bit) , always lost the connection to cygwin server , ex.:

[CSS]MCL> S ^TEST(1)=1
[CSS]MCL> F I=1:1:1000 S ^TEST(I)=I
[CSS]MCL> F I=1:1:10000 S ^TEST(I)=I
198323334 [main] mumps 2552 transport_layer_pipes::connect: lost connection to cygserver, error = 2
FATAL MUMPS ERROR occured!!
SemOp() failed
errno = 11 Resource temporarily unavailable
Segmentation fault (core dumped)

Somebody , any idea to solution ?
Configuration on cygwin side is default !

Author:  whitten [ Thu Jan 10, 2013 8:11 am ]
Post subject:  Re: Windows version of MUMPS V1 now available on SourceForge

My experience with cygwin is several years old. But I do know that its Windows interface is finicky.
Is there a way to make sure you have the latest versions of some of the low-level interfaces loaded?
I seem to recall that cygserver runs as a MS Windows service. I expect that Windows 7 code has been changed when they were tightening up security.

It is possible that the code referencing that message is at http://jojelino.net78.net/2012-08-30-cy ... Pr75O.html about line 325 (or at least code within a few versions of it) The message "SemOp() failed" seems to be implying that there are semaphors involved. The code before line 325 seems to be implying that "2" is ERROR_FILE_NOT_FOUND. Is it possible that it just isn't waiting long enough to create the named pipe ?

Author:  cais28 [ Thu Jan 10, 2013 8:18 am ]
Post subject:  Re: Windows version of MUMPS V1 now available on SourceForge

Thanx David

I'm think the problem have in C source function call syntax of named pipe .
Why changed in windows7 ? .. on XP working perfect :cry:

...or windows7 security settings ? i'm will check this side .....

Author:  jasmyndube [ Tue Oct 24, 2017 1:58 am ]
Post subject:  Re: Windows version of MUMPS V1 now available on SourceForge

I expect that Windows 7 code has been changed when they were tightening up security.

Page 1 of 1 All times are UTC - 8 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/